
Soft Bounces for Emails to Microsoft 365 Recipients
Started 18 Jun at 02:15pm CEST, resolved 20 Jun at 11:09pm CEST.
Resolved
To resolve the issue of emails experiencing soft bounces when sent to Microsoft 365 recipients, we have made a change to the subdomain used for sending emails.
The subdomain change has been successfully applied, and initial tests indicate that the issue has been resolved. Emails should now be delivered successfully to Microsoft 365 recipients. We are currently monitoring the situation to ensure the issue remains resolved.

Updated
The IP address change has been successfully applied, and initial tests indicate that the issue has been resolved. Emails should now be delivered successfully to Microsoft 365 recipients. We are currently monitoring the situation to ensure the issue remains resolved.
Updated
Our team is actively working with Microsoft to resolve this issue. We have opened a ticket with Microsoft and the investigation is ongoing. We will keep you updated on the progress and resolution of this issue.

Created
We would like to inform you that currently, approximately 10% of our sent emails to Microsoft 365 recipients are experiencing soft bounces. This means these emails are temporarily undeliverable. We apologize for any inconvenience this may cause.