Get in touch
Back
Resolved

Email Problems

Started 21 Feb at 04:45pm CET.

app.absentify.com teams.absentify.com
Created

Our e-mail provider has problems, we can no longer send e-mails. This concerns emails to confirm requests and support ticket emails.
OutlookE-Mail invitations are not affected

Posted 21 Feb at 04:45pm CET.